Need help with a propane space heater!

Discussion in 'Homesteading Questions' started by ovsfarm, Dec 19, 2004.

  1. ovsfarm

    ovsfarm Well-Known Member Supporter

    Messages:
    1,730
    Joined:
    Jan 13, 2003
    Hi,

    We have an Empire wall-hung space heater that is controlled by a thermostat. Worked fine last winter. When we tried to fire it up today, we can't get the actual heater part to ignite. The pilot light comes on and heats the little element thing, so it will stay lit, but when we adjust the thermostat (even up to a very high temp), the pilot light is the only thing that is on. We turn the proper knob to the ON position but that has no effect. Took the tank in to be topped off recently and it is full. So what are we missing? Is it just that the pressure valve is stuck? And how best to unstick it without blowing ourselves up? I'd appreciate any suggestions as it is supposed to get down to around 7 or 8 tonight and that heater helps keep our water lines unfrozen. We do have a back up system, but this is our most economical (and usually efficient) method of keeping the lines warm.

    Thanks,
    Lori
     
  2. uncle Will in In.

    uncle Will in In. Well-Known Member Supporter

    Messages:
    7,154
    Joined:
    May 11, 2002
    We had a propane space heater a few years ago and back then the thermocoupler ( the little thingy sticking up into the pilot) would get ash and corrosion on it and would not allow the gas valve to open and start the fire. I would take a paring knife and reach in to the coupler scraping off the corrosion. This let it get hot enough to work. Maybe yours isn't the same as in days of old???
     

  3. moopups

    moopups In Remembrance

    Messages:
    7,102
    Joined:
    May 12, 2002
    Location:
    In beautiful downtown Sticks, near Belleview, Fl.
    Most all propane heaters has a safety device that must be heated by the pilot flame for it to come on, look near the pilot flame for a thin tube that carries the material that allows it to flow to the burner. E mail Old Hoot at the CF forum if you can find him, he is propane experienced as it was his past job.
     
  4. Bruce in NE

    Bruce in NE Well-Known Member

    Messages:
    329
    Joined:
    Dec 11, 2002
    I've also got an Empire and had the same problem a while back -- pilot light lit but furnace no work. I finally got it to work by jiggling the thermostat housing mounted on the wall. Apparently it had a short or got dirty. Anyway, the thrmostat works again. You might try that.
     
  5. oldhoot

    oldhoot In Remembrance

    Messages:
    625
    Joined:
    May 4, 2002
    Dependin if the heater is a non electric valve or has to be plugged in. If it's the non-electric it will have a hydrolic gas valve--even if it has a wall thermostat. That type has to have a really good pilot light--burnin Blue without any yellow in the flame. They are called a mili-volt or pilot generator safety and if it doesn't get hot enough it will not generate enough mili-volt to open the gas valve. Clean the pilot burner and pilot orfice. For a quick fix try blowin on the pilot burner with a small metal tube. Sometimes this will clean it enough to make it work.

    If it's the electric valve it could be the valve is stuck. Try rappin it on the side with something that's kinda heavy but not too hard. Dont wanna break the valve body! These electric valves have a thermocouple that the pilot burns against. The sole purpose of the T-couple is for a safety. When/if the pilot goes out the t-couple will cool off and will close the valve. Make sure you have 24 volts present at the valve. A small transformer will be located somewhere on the heater and sometimes they will get zapped by lightning even if you don't have any other damaged items.

    If you are handy try this little procedure if all the above fails. Unmplug the electric cord [if this is the electric model] from the wall and remove the thermostat wires from the gas valve. Install a little jumper wire between the two terminals where the t-stat wires were connected. Plug in and see if it fires. If it does either the t-stat is bad or the wirin to it or the coil in the valve is weak and failin.

    If yours is the non-electric/hydrolic vavle--try the same procedure on it as the electric model. It's only less than 1 volt so don't wirry about gettin electricuted! If it fires--could be the wirin to the t-stat or the stat itself--or a dirty pilot.

    Hope this helps--if you have one different than I've described-holler and well try to walk you thru it.

    Thanks Moo for the heads up. Too darned cold to be without heat now!!! oldhoot