Homesteading Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,527 Posts
Discussion Starter #1
I got this thing 4 years ago and it stopped working after the first month... I know I know, why didn't I call to have them fix it... it's personal!

It will not accept a charge. It says it is after a few minutes but even the horn won't work... only the lights telling me it needs charged.

Any ideas? The holidays are coming and I'll really need it bad this year.
 

·
Still an :censored:
Joined
·
15,870 Posts
My guess is either the battery or the charging circuit. Can you remove the battery easily and have someone check it? I have no idea what kind of batteries those things use. Someone here will know.
 

·
Premium Member
Joined
·
25,168 Posts
Good troubleshooting start is this, does it work while it's plugged in? If so it's the battery. If not it could be anything from connections to a bad cord.

The batteries aren't cheap. Cost over $50 each when I got the ones for my scooter. If you have a Batteries Plus in your area they either have them or can get them.
 

·
Premium Member
Joined
·
15,516 Posts
Good troubleshooting start is this, does it work while it's plugged in? If so it's the battery. If not it could be anything from connections to a bad cord.

The batteries aren't cheap. Cost over $50 each when I got the ones for my scooter. If you have a Batteries Plus in your area they either have them or can get them.
I'll try to remember to ask DH where he orders ours. I have two scooters and we look for the most economical ones.

BTW, mine will not work if they are plugged in. I think that it is a safety feature.
 

·
Premium Member
Joined
·
25,168 Posts
Must not be a feature in all of them. Of course my grandpa's is nearly 20 years old. And the ones at most stores can be driven while plugged in. But good catch, I didn't know that was a possible feature.
 
1 - 8 of 8 Posts
Top