Homesteading Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter #1
I posted this in the gardening forum, but I am desperate for help, so I'm posting it here too. Something is wrong with my saskatoon berry bush. A cotton like substance is taking over the leaves and seems to be slowly killing the bush. Please see pics for details. Does anyone know what is causing this? How can I treat it? Thanks for any advice.
http://www.msnusers.com/mountainhighgarden/shoebox.msnw
 

·
Registered
Joined
·
4,222 Posts
Have you picked open the fluff to see if ther is larvae inside?

I would cut off and burn all the stems with fuzzies and spray with a fungicide as it appears you also have black spot, but the fuzzy stuff is a bit too heavy for powdery mildew
 

·
Registered
Joined
·
299 Posts
Discussion Starter #3
I haven't picked it open yet. I knew I should have before I posted here... :eek: I'll check it tomorrow and update you. Thanks for the reply.
 

·
Registered
Joined
·
4,222 Posts
???????
 

·
Registered
Joined
·
248 Posts
re saskatoon berry:

http://www1.agric.gov.ab.ca/$department/deptdocs.nsf/all/opp2562#SaskatoonBudMoth

I can't tell from the phots in the above site, but if all fails, you might contact the lady from the website:

Shelley Barkley
Information Officer
Crop Diversification Centre South
Main Floor, A. Griffin Office Building
Crop Diversification Centre South
Brooks, AB T1R 1E6
Phone (403)362-1308
Fax (403)362-1306
Email [email protected]

best

owhn
 

·
Registered
Joined
·
248 Posts
I'm sorry the link still works for me.

you might try this one:

http://www1.agric.gov.ab.ca/$department/deptdocs.nsf/all/opp2562?opendocument

owhn
 
1 - 7 of 7 Posts
Top