'95 S-10 won't start and has weird electrical problems

Discussion in 'Shop Talk' started by clovis, May 22, 2006.

  1. clovis

    clovis Well-Known Member

    Messages:
    9,511
    Joined:
    May 13, 2002
    A month ago, I bought a used S10 with 162,000 miles, V6, tilt wheel.

    Truck has been starting absolutely fine, including three times this morning. Went out an hour ago, and it won't start.

    The first turn of the key....no electrical power to anything...no radio, no lights, etc. I thought the battery was completely dead.

    Will not even attempt to turn over.

    I tried again, jiggling the key. Some power to some accessories, then nothing.

    Repeated jiggling, some more power, but not full power. Then I removed the key, and am getting weird electrical noises.....some humming and sounds like a kitten is stuck under the dash!!!!!!

    Went back out and the stupid truck restarted like nothing happened.

    Shut it off, and now it won't start. Same weird humming and kitten screaming noises.

    The noises stay going even after the key is removed from the ignition!!!!

    The noises stay going until I turn on another accessory, like the lights, but start again until I turn the lights off.

    Other weird things.....radio sometimes plays for 5 seconds. Sounds like the turnsignal flasher is flashing thru the speakers, but none of the other sounds are thru the speakers. They sound like they are buzzing thru the accessory on buzzer. The turn signals have never worked since I have owned this truck.

    Some at UHaul wired a trailer plug to the harness in the rear a long time ago. Could this have anything to do with the problem? The ground clip is rusty.

    Again, no prior problems with this truck. No forewarning to any of these problems.

    HELP!!!!!!!!

    Thank you in advance! You guys are life savers!!!!
    Clove
     
  2. Shrek

    Shrek Singletree Moderator Staff Member Supporter

    Messages:
    11,609
    Joined:
    Apr 30, 2002
    Location:
    North Alabama
    Is there a lot of play in the tilt column or has the windshield wipers been frequently swiping on their own when turning the wheel?

    I have had this occur in two S-10s and it was followed by system failure in the switch. One time I had the column guts replaced, the second time my mechanic replaced the tilt column with one from a totaled wreck. Same labor times applied , however the parts for the column rebuild cost me $25 more than he charged me for the salvaged column in the final billings.
     

  3. clovis

    clovis Well-Known Member

    Messages:
    9,511
    Joined:
    May 13, 2002
    Thanks for the reply....

    I haven't had any type of problems....no forewarnings....nothing weird until today. No play in the column or tilt.

    Can you remember and possibly explain a little more about what your problems and diagnosis were?

    Thanks!!!
     
  4. Cabin Fever

    Cabin Fever Life NRA Member since 1976 Supporter

    Messages:
    15,598
    Joined:
    May 10, 2002
    Location:
    Between Crosslake and Emily Minnesota
    Start with the simple stuff. If you have absolutely no lights (not even dim) when you pull the headlight switch, then more than likely you have a poor battery terminal-to-cable connection or a poor negative cable-to-ground connection. Make sure your battery terminals are clean and the battery cables are tight. If that doesn't solve the problem, then make sure the negative cable has a solid ground to the engine block. If the headlights still don't come on...well, I dunno.
     
  5. clovis

    clovis Well-Known Member

    Messages:
    9,511
    Joined:
    May 13, 2002
    Got it fixed.

    Loose positive battery cable. I have seen some weird stuff in my life, but nothing like this. would have sworn it was a problem in the column.

    Thanks so much for your time!!!!!!!!!!!!!!!!!!!!!!!!!!!
    clove
     
  6. Gideon

    Gideon Well-Known Member

    Messages:
    460
    Joined:
    Sep 14, 2005
    Glad you found the trouble and was an easy fix. We are having a little "get together" this fall in central southern NC and the theme of it is preventive maintence,emergency actions to make it go,and field fixes/short cuts. If in the area or interested just E me. You would be surprised what one can do to a vehicle to make it go when the thing conks out on you. We may even do some videos of them for those not able to come.